31 de julio de 2009

Scripts en Python para The Gimp

Ayer tomé valor. Decidí instalar Python en mi PC para poder ejecutar scripts en Python en The Gimp.

La imágen de la izquierda es del menú Filtros luego de la instalación. Vean la barra azul. Se agrega también un nuevo menú, Python-Fu, a la derecha del menú Filtros.

Y ya que instalaba algo nuevo, salté de versión 2.6.5 de The Gimp a la 2.6.6. Además decidí borrar las versiones más antiguas de The Gimp que tenía instaladas en mi PC que, dicho sea de paso, tiene Windows XP.

Como las versiones más modernas de The Gimp incluyen GTK+ en el setup, desintalé la versión 2.10 de GTK+.

Así, mi computadora quedó sin nada relacionado a The Gimp, excepto los archivos personales que se guardan en la carpeta del Usuario. Eso incluye los plugins que habia agregado, los presets de Gimpresionist, los filtros, etc.

Una vez "limpiada" mi PC de The Gimp, obtuve de Internet lo siguiente:
  • The Gimp 2.6.6
  • The Gimp Help 2.2.4
  • Python 2.6.2
  • PyCairo
  • PyObject
  • PyGTK
Luego de obtenerlos, los he instalado en el siguiente orden:
  1. Python
  2. PyCairo
  3. PyObject
  4. PyGTK
  5. The Gimp
  6. The Gimp Help
Todo salío bien, o casi. Sólo tengo un inconveniente pequeño con la ayuda de The Gimp. Así que el esfuerzo valió la pena. Ahora mi Gimp acepta esos bellos scripts en Python que parecen abundar en Internet. Una de las grandes ventajas de Python es que es multiplataforma, o sea que se puede ejecutar los scripts en cualquier sistema operativo. Eso significa que se puede usar código escrito en Linux en XP sin ninguna modificación. Pronto escribiré sobre algunos de estos scripts en el blog.

Algunos comentarios sobre los cambios hechos con el software:
  • tuve que crear un .bat para cambiar de idioma a The Gimp. Esto es, por no tener instalado GTK+ con el setup original, sino con los instaladores de la version 2.6.6 de The Gimp que incluye las librerías de GTK+. Ver esta entrada sobre el cambio de idioma.
  • Tuve que reinstalar PSPI, aunque ese fue un error mío al desintalar ese directorio que no correspondía etc.
  • Lo curioso es que no puedo ver la ayuda de The Gimp con el visor interno, sino que debo abrir el navegador para ver la ayuda en línea. Aún no pude solucionar este inconveniente.
Fuentes:
Python
PyCairo + PyObject + PyGTK
The Gimp y The Gimp Help

4 comentarios:

NaylaG dijo...

Hola:

Muy instructivo tu artículo. Mientras me animo a bajar la versión 2.8, estoy pensando probar Python en mi todavía versión 2.6. Pienso seguir tus instrucciones, pero tengo algunas dudas:

En la página del proyecto, sólo hay una versión (actualmente) del instalador para windows: la 2.6.12 (gimp-2.6.12-i686-setup-2). Casualmente es la que ya tengo, así que al desinstalar/reinstalar manejaré la misma y no hay problema. Lo que ya no me queda claro es qué versión de Python, PyCairo y PyObject debería escoger (o si da lo mismo). Cualquier comentario me será de utilidad. Gracias.

EFI dijo...

NaylaG

Gracias por leer mi blog. Agradezco también tu crítica. Te recomiendo instalar la versión 2.8 directamente, ya que Python está incluído en los instaladores de esa versión 2.8 de Gimp.

También recomiendo no desinstalar la 2.6 y hacer una instalación en otra carpeta de la 2.8. Así, si tienes alguna incompatibilidad - problema etc, sigas con tu versión 2.6 disponible.

Lamento no recordar que versiones usé de PyCairo etc.

Saludos

NaylaG dijo...

Hola EFI, gracias por tu respuesta. Te comento que la versión GIMP 2.8 me ha ido bien en Win7. Sin embargo, tengo una pc viejita con WinXP Home y 256 MB de RAM donde de plano no anda, así que le instalé la versión 2.6.12 y le agregué Python sin contratiempos. Si me permites, te comento lo que hice, en caso de que alguien todavía tenga un equipo viejo y la versión 2.8 exceda sus capacidades.

1.- Instalé Python 2.6.6 (python-2.6.6.msi). Reinicié.

2.- Instalé Pygtk all-in-one (pygtk-all-in-one-2.24.0.win32-py2.6.msi) éste instala los módulos PyGTK, PyCairo y PyObject en un solo paso. Reinicié.

Hasta aquí todos con sus opciones por defecto.

3.- Instalé finalmente Gimp 2.6.12 (concretamente gimp-2.6.12-i686-setup-2.exe), escogiendo, en la ventana "Ready to install" el botón "Customize". Dos ventanas después, en "Select Components", en la pestaña desplegable "Full/Compact/Custom
installation", la opción "GIMP Python extension" apareció activa, así que escogí "Full installation" y continué con la instalación. Reinicié.

Esta combinación de instaladores fue la que me funcionó (probé otros sin resultados compatibles), siempre partiendo de la versión del instalador 2.6 para Windows que permanece en la página oficial de GIMP.

Reitero mi agradecimiento por tu detallado artículo, me fue de mucha ayuda a la hora de decidir qué opciones escoger para mis dos computadoras.

Saludos

EFI dijo...

Gracias a vos, NaylaG. Tus comentarios merecen resaltarse, lo cual haré en una próxima entrada. Espero tener tiempo para hacerla pronto. Saludos